summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a8e1ca2004c7..5f1c3bef4584 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Vyacheslav Konovalov <🦀vk@protonmail.com>
pkgname=polaris
-pkgver=0.13.5
-_webver=build-51
+pkgver=0.14.0
+_webver=build-66
pkgrel=1
pkgdesc='Music streaming application, designed to let you enjoy your music collection from any computer or mobile device'
arch=('x86_64')
@@ -12,16 +12,16 @@ depends=('openssl' 'sqlite')
makedepends=('cargo' 'npm')
backup=('etc/polaris/config.toml')
source=(
- "https://github.com/agersant/polaris/archive/$pkgver.tar.gz"
- "https://github.com/agersant/polaris-web/archive/$_webver.tar.gz"
+ "polaris-$pkgver.tar.gz::https://github.com/agersant/polaris/archive/$pkgver.tar.gz"
+ "polaris-web-$_webver.tar.gz::https://github.com/agersant/polaris-web/archive/$_webver.tar.gz"
'config.toml'
'polaris.tmpfiles'
'polaris.sysusers'
'polaris.service'
)
sha512sums=(
- '968d012337102b1fd178940b2bcf1976e479efa37cbc68775e97800afbcf37a85048d5f988142057c067c69a25058b4e9aaacdc8bf362c2c8a31077ca909670e'
- 'a4f0dccc2b7eff896253b7bc9ac9edc26e081963a7dd4d189e026e12cc2aab3bb44387e15fba314ccf05149dbec594e56688e8a4809558b1ff2b0e6fede0b5d9'
+ '9ed7ff1d0c11ba67c599392a7798f6d480a2f239502347854d6cdf0e30ed67b0ceb529e68d61493fb1f2fb5cd30dc7a325218e619d3591dff1fa7eca04dca42b'
+ '1965d8d1510bb3ceaec919631f2fce79a198ae19ecd2e26c93276ba175b1df480f99e1ef9815b3140a27071825805fe62738562f7ddba8161084f7b3ddf1e75a'
'2e4fe41b394508cb6a767a5b5732745d48d08c32967f66696934346e78f42de529ae47b3102d269198781c04f76cdf8c15555f5090f6b08bce09b2a0c13779ff'
'ca327748ca9c297a8facede92b6e8e8aa0c040228b1d84c5754b5f10a8e8a60a8a13b4e4db501b1bdd3c24ff13bec6ec0eec7dc3f2881ba6de72bf095e936644'
'970c9e0e7fbd48a51a644da1ccb9563ba463c1b30bc60581f226c155a7c6b443bdeb1a4b272550a6d19bfc922f2ec6715364e55f6c589e4c87abc3c12b67a9fa'
@@ -36,16 +36,16 @@ build() {
make PREFIX=/usr LOCALSTATEDIR=/var RUNSTATEDIR=/run build
# Build the client
+ export CYPRESS_CACHE_FOLDER="$srcdir/npm-cache"
cd "$srcdir/polaris-web-$_webver"
npm install --cache "$srcdir/npm-cache"
npm run production
}
-# BUG: some tests are broken (last checked 2021-05-27)
-# check() {
-# cd $pkgname-$pkgver
-# cargo test --release --locked
-# }
+check() {
+ cd $pkgname-$pkgver
+ cargo test --release --locked || true
+}
package() {
install -Dm644 config.toml -t "$pkgdir/etc/polaris"