summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 730558c646dd..7891bcd3ddaf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
pkgname=polo-bin
_name=polo-file-manager
-pkgver=18.6
+_branch=18.8
+pkgver=${_branch}.2
_channel=beta
pkgrel=1
pkgdesc="A modern, light-weight GTK file manager for Linux, currently in beta (.deb binary version)"
-arch=('i686' 'x86_64')
+arch=(i686 x86_64)
url="https://teejee2008.github.io/polo/"
-license=('GPL2')
-depends=('gtk3' 'libgee' 'libsoup' 'vte3' 'rsync' 'gvfs' 'p7zip')
-makedepends=('chrpath')
+license=(GPL2)
+depends=(gtk3 libgee libsoup vte3 rsync gvfs p7zip)
optdepends=('mediainfo: read media properties from audio and video files'
'fish: terminal shell'
'perl-image-exiftool: read EXIF properties from JPG/TIFF/PNG/PDF files'
@@ -21,18 +21,17 @@ optdepends=('mediainfo: read media properties from audio and video files'
'gnome-disk-utility'
'lzop'
'polo-donation-plugins')
-provides=('polo')
-conflicts=('polo' 'polo-bin')
-source_i686=("https://github.com/teejee2008/polo/releases/download/v${pkgver}-${_channel}/${_name}-v${pkgver}-i386.deb")
-source_x86_64=("https://github.com/teejee2008/polo/releases/download/v${pkgver}-${_channel}/${_name}-v${pkgver}-amd64.deb")
+provides=(polo)
+conflicts=(polo)
+source_i686=("https://github.com/teejee2008/polo/releases/download/v${_branch}-${_channel}/${_name}-v${pkgver}-i386.deb")
+source_x86_64=("https://github.com/teejee2008/polo/releases/download/v${_branch}-${_channel}/${_name}-v${pkgver}-amd64.deb")
-sha256sums_i686=('61e267149c39dd53b03a1b0480d38b6cac877b693edcc492bc10a29c5edb2080')
-sha256sums_x86_64=('03807c08094ac703230f6b4a1ece644e54ed446e99495c0cc65885da51032086')
+sha256sums_i686=('ae235d638de83b86d5490553e7e99bbe53b4609f8d99a04babd6047a94aa8b0b')
+sha256sums_x86_64=('18e7217e57b9b422af5431ba9eaded1a44775a0781a1dc7abf50ed736bbbdeb4')
package() {
bsdtar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}/"
install -d $pkgdir/usr/bin
ln -s /usr/bin/polo-gtk $pkgdir/usr/bin/polo
rm $pkgdir/usr/bin/polo-uninstall
- chrpath --delete ${pkgdir}/usr/bin/polo-gtk
}