summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a3d954a9bdab..be6fc43c5d88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=pop-shell-theme-git
_pkgname=gnome-shell-theme
-pkgver="r98.21a1337"
-pkgrel=2
+pkgver=r182.8c7ef1b
+pkgrel=1
pkgdesc="This is the GNOME Shell theme that goes along with the Pop GTK Theme."
arch=("any")
url="https://github.com/pop-os/gnome-shell-theme"
@@ -30,7 +30,6 @@ optdepends=(
"ttf-fira-sans: Recommended font for window titles and interface"
"ttf-fira-mono: Recommended monospace font"
"ttf-roboto-slab: Recommended font for documents"
- "pop-gtk-theme-git: Recommended gtk theme"
"pop-icon-theme-git: Recommended icon theme"
)
provides=("${_pkgname}")
@@ -38,6 +37,11 @@ conflicts=("${_pkgname}")
source=("git+https://github.com/pop-os/gnome-shell-theme.git")
sha256sums=("SKIP")
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
build() {
cd "${_pkgname}"
make clean