summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 16 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cbfbebf6b44c..065553cc022c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Szentesi Botond
+# Patches By: Marie Ramlow
pkgname=powercord-git
_pkgname=powercord
-pkgver=r1280.61c8dae5
+pkgver=r1390.8a471180
pkgrel=1
-pkgdesc="A lightweight discord client mod focused on simplicity and performance."
+pkgdesc="A lightweight discord client mod focused on simplicity and performance. Includes a patch to fix mouse thumb buttons."
arch=("any")
url="https://github.com/powercord-org/$_pkgname"
-license=('Porkord')
-depends=('nodejs' 'git' 'npm')
+license=('MIT')
+depends=('nodejs' 'git' 'npm' 'discord-canary')
makedepends=('jq')
source=(
"git+https://github.com/powercord-org/powercord#branch=v2"
@@ -17,17 +18,19 @@ source=(
"pc-settings_index.js.patch"
"pc-updater_index.js.patch"
"pc-updater_settings.jsx.patch"
+ "browserWindow.js.patch"
"powercord.8"
)
-md5sums=(
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
+sha256sums=(
'SKIP'
+ '4636c2b0db9e25ee2a70d75352e8f5ae5d03d512b70e1a4b300048396d98b661'
+ 'a3543f74cbe07752f81fd0b5a2b29647e7138acd11ae76a6b723e28928504fb0'
+ 'd8174069f7f4180d770a942030bd1d90275e2a000088d9caa94aa44b79f7d7ee'
+ '59356c741dea8192e340f009c5d148e526c1f723be91a8224489ed66d6b3a070'
+ 'b9e17f6091ea5eaee58d625aa9921f14b579f068eb7b4bd7a70068413b614bc3'
+ '1f3b303f5ddfb04badb1c909f3da2cee49ffa6a13e4a8ebb255aef715d381c6f'
+ 'd554cc48d14e4085bf3976a5b3439abb6fbea94c7593240b717d9883ee923b8d'
+ '0f06f85a3d80b00cf577d8d3a38589e8230bb7480871eca4c7ee6b04f28b61da'
)
options=('!strip')
@@ -38,6 +41,7 @@ prepare() {
patch -u ${srcdir}/${_pkgname}/src/Powercord/plugins/pc-settings/index.js -i ${srcdir}/pc-settings_index.js.patch
patch -u ${srcdir}/${_pkgname}/src/Powercord/plugins/pc-updater/index.js -i ${srcdir}/pc-updater_index.js.patch
patch -u ${srcdir}/${_pkgname}/src/Powercord/plugins/pc-updater/components/Settings.jsx -i ${srcdir}/pc-updater_settings.jsx.patch
+ patch -u ${srcdir}/${_pkgname}/src/browserWindow.js -i ${srcdir}/browserWindow.js.patch
cd "${srcdir}/${_pkgname}"
local _revision="$(git rev-list HEAD | head -n 1)"