summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 3 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd1ddaa43b11..534a93e01c17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,15 @@
pkgname="pretzel-web"
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Open-source, browser-local data exploration using DuckDB-Wasm and PRQL"
url="https://pretzelai.github.io/"
license=("Apache-2.0")
arch=("any")
-makedepends=("npm")
-source=("$pkgname.tar.gz::https://github.com/pretzelai/pretzelai/archive/refs/heads/main.tar.gz")
+source=("$pkgname.zip::https://github.com/pretzelai/pretzelai.github.io/archive/refs/heads/main.zip")
b2sums=("SKIP")
-build(){
- cd "pretzelai-main"
- npm install
- npm run build
-}
-
package(){
- cd "pretzelai-main"
install -d "$pkgdir/usr/share/webapps"
- mv "build" "$pkgdir/usr/share/webapps/pretzel"
+ mv "pretzelai.github.io-main" "$pkgdir/usr/share/webapps/pretzel"
}