summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ff40138e866f..8a11022fa303 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=processing4
pkgver=4.0b2
-pkgrel=1
+pkgrel=2
arch=(x86_64)
pkgdesc='Programming environment for creating images, animations and interactions'
url='https://github.com/processing/processing4'
@@ -13,10 +13,12 @@ provides=('processing')
options=(!strip)
source=("https://github.com/processing/processing4/archive/processing-$((1275+${pkgver##4.0b}))-$pkgver.tar.gz"
'https://download.processing.org/reference.zip'
- disable_update_check.patch)
+ disable_update_check.patch
+ disable_native_dialogs.patch)
sha256sums=('060a126877d63ddb048cd389c505f0d502ba4f00bb59be38b99250b1f7006b2d'
'fabe7420a714f450a6b1430f13fc46f14ba52db57af360365c6a7fd96d0b642f'
- '35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30')
+ '35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30'
+ '500d00811031c0445416b6112972aa1f7a377092dd3b8565d79ead3fdfc62451')
prepare() {
# Create .desktop file
@@ -31,6 +33,9 @@ prepare() {
# Disable update check in default preferences
patch $pkgname/build/shared/lib/defaults.txt < disable_update_check.patch
+
+ # Disable native dialogs in default preferences
+ patch $pkgname/build/shared/lib/defaults.txt < disable_native_dialogs.patch
}
build() {