summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c990b46b4a0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Dylan Araps <dylan.araps@gmail.com>
+pkgname=promptless
+_pkgname=promptless
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="A super fast and extremely minimal shell prompt."
+arch=('any')
+url="https://github.com/dylanaraps/${_pkgname}"
+license=('MIT')
+provides=($_pkgname)
+conflicts=($_pkgname)
+depends=()
+optdepends=()
+makedepends=('git')
+source=("$pkgname::git+https://github.com/dylanaraps/promptless.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags --long | sed -r -e 's,^[^0-9]*,,;s,([^-]*-g),r\1,;s,[-_],.,g'
+}
+
+package() {
+ cd "$pkgname"
+ install -D -m755 promptless.sh "$pkgdir/usr/bin/promptless.sh"
+}
+
+post_install() {
+ echo
+ echo "add 'promptless.sh' to your .bashrc or equivalent."
+ echo
+}