summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b23240a6e629..98f99db18859 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,33 @@
-# Maintainer: xantares <xantares09 at hotmail dot com>
+# Contributor: xantares <xantares09 at hotmail dot com>
pkgname=psp-opengl
-pkgver=0.2
+_commit=30ffef7bb75ba70eccede93288d7bb429a2e4709
+pkgver=r12.30ffef7
pkgrel=1
-pkgdesc="hardware-accelerated implementation of OpenGL for the Playstation Portable (psp)"
+pkgdesc="OpenGL libraries for PSP"
arch=(any)
-url="http://www.goop.org/psp/gl/"
-license=('GPL')
+url="https://github.com/pspdev/pspgl"
+license=('BSD')
groups=('psp')
depends=('psp-sdk')
-makedepends=('psp-gcc')
+makedepends=('psp-gcc' 'git')
options=('!buildflags' '!strip' 'staticlibs')
-source=("git+https://github.com/pspdev/psp-ports.git")
+source=("git+https://github.com/pspdev/pspgl.git#commit=$_commit")
md5sums=('SKIP')
+pkgver() {
+ cd pspgl
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
build()
{
- cd "$srcdir/psp-ports/pspgl"
+ cd "$srcdir/pspgl"
make
}
package()
{
- cd "$srcdir/psp-ports/pspgl"
+ cd "$srcdir/pspgl"
make install PSPPATH="$pkgdir"/usr/psp
}
-