summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 21 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d01dda3ec2cd..6dfc2bba6f5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,35 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
-# Contributor: Dominic Radermacher <blip@mockmoon-cybernetics.ch>
+# Maintainer: Markus Jochim <contact-markus@mensing-jochim.de>
+# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Author: Dominic Radermacher <dominic@familie-radermacher.ch>
_pkgname='ptouch-print'
pkgname="${_pkgname}-git"
-pkgver=1.4.3.r0.g32c0d3b
+pkgver=1.5.r10.g01d6614
pkgrel=1
-pkgdesc="Command line tool to print labels on Brother P-Touch printers"
-arch=('x86_64')
-url='https://mockmoon-cybernetics.ch/computer/p-touch2430pc/'
+pkgdesc="Command line tool to print text or graphic labels on Brother P-touch printers like PT-2430PC"
+arch=('x86_64' 'i686' 'armv7h' 'armv6h')
+url="https://dominic.familie-radermacher.ch/projekte/ptouch-print/"
license=('GPL3')
-depends=('gd' 'libusb')
-makedepends=('git')
+makedepends=('cmake' 'git')
+depends=('libusb>=1.0' 'gd>=2.0.16')
provides=("${_pkgname}")
-source=("git+https://mockmoon-cybernetics.ch/cgi/cgit/linux/${_pkgname}.git")
+conflicts=("${_pkgname}")
+source=("git+https://git.familie-radermacher.ch/linux/${_pkgname}.git")
sha256sums=('SKIP')
pkgver() {
- git -C "${_pkgname}" describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${srcdir}/${_pkgname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/v//g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
-
build() {
- cd "${_pkgname}"
- autoreconf --install
- ./configure --prefix=/usr
- make
+ cd "${srcdir}/${_pkgname}"
+ mkdir -p build && cmake --fresh -B build && cmake --build build
}
-
package() {
- make DESTDIR="${pkgdir}" -C "${_pkgname}" install
- install -Dm644 -t "${pkgdir}/usr/share/man/man1" "${_pkgname}/${_pkgname}.1"
- install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" "${_pkgname}/README"
+ cd "${srcdir}/${_pkgname}"
+ DESTDIR="${pkgdir}" cmake --install build
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" "README"
}
-
-# vim: ts=2 sw=2 et: