summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6787b13f6921
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# AUR Category: devel
+# Maintainer: Alexander Koch <lynix47@gmail.com>
+
+pkgname=ptxdist-2018.12
+_realname=ptxdist
+pkgver=2018.12.0
+pkgrel=1
+pkgdesc="Embedded Linux build system, pinned 2018.12 release"
+arch=('x86_64')
+url="http://www.ptxdist.org"
+license=('GPL')
+depends=('dialog' 'flex' 'bison' 'patch' 'python2')
+source=("http://www.pengutronix.de/software/ptxdist/download/${_realname}-${pkgver}.tar.bz2")
+md5sums=(''d690c207aa27ed2be7fd392ad2809af3)
+
+build() {
+ cd "${srcdir}/${_realname}-${pkgver}"
+
+ ./configure --prefix=/usr --with-python=/usr/bin/python2
+ make
+}
+
+package() {
+ cd "${srcdir}/${_realname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ mv ${pkgdir}/usr/bin/ptxdist ${pkgdir}/usr/bin/${pkgname}
+}
+
+# vim: ts=4