summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index daae77487777..ec7f24115caf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,16 @@
# Maintainer:
# Contributor: Stefan Tatschner <stefan@rumpelsepp.org>
+## useful links
+# https://pyinfra.com/
+# https://github.com/pyinfra-dev/pyinfra
+
_pkgname="pyinfra"
pkgname="$_pkgname"
pkgver=2.9.2
-pkgrel=1
-pkgdesc="pyinfra automates infrastructure super fast at massive scale"
-url="https://pyinfra.com/"
+pkgrel=2
+pkgdesc="automate infrastructure super fast at massive scale"
+url="https://github.com/pyinfra-dev/pyinfra"
license=('MIT')
arch=('any')
@@ -18,24 +22,26 @@ depends=(
'python-gevent'
'python-jinja'
'python-paramiko'
+ 'python-pywinrm'
'python-yaml'
-
- 'python-setuptools' # silence namcap
)
makedepends=(
'python-build'
'python-installer'
'python-wheel'
+ 'python-setuptools'
)
_pkgsrc="$_pkgname-$pkgver"
_pkgext="tar.gz"
-source=("$_pkgsrc.$_pkgext"::"https://github.com/Fizzadar/pyinfra/archive/v$pkgver.$_pkgext")
+source=("$_pkgsrc.$_pkgext"::"https://github.com/pyinfra-dev/pyinfra/archive/v$pkgver.$_pkgext")
sha256sums=('10a4d7698f60ff142541d7e5c8173147b3613489c720899f3b92e278f2e95789')
prepare() {
cd "$_pkgsrc"
rm -rf tests
+
+ sed -E -e '/configparser/d' -i setup.py
}
build() {