summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 49227837f7d7..010c60611330 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Alex Wicks <alex@awicks.io> (https://aur.archlinux.org/account/aw1cks)
-pkgname=pyslam
-_name=PySLAM
-pkgver=1.2.0
+pkgname='pyslam'
+_name='PySLAM'
+pkgver=1.2.1
pkgrel=0
-pkgdesc="Python implementation of Source Live Audio Mixer"
+pkgdesc='Python implementation of Source Live Audio Mixer'
arch=(any)
url="https://gitlab.com/aw1cks/${pkgname}"
license=('AGPL3')
@@ -27,7 +27,7 @@ replaces=()
backup=()
options=(!emptydirs)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-$pkgver.tar.gz")
-sha256sums=("590939b51b106c3b1a916da030d677491eb546a4a331e1c5208b44bc83756f18")
+sha256sums=('fa645ada76b68fc6ac62fb31d4ebcb561a7afe0ef23301557f6205341355dfea')
build() {
cd "${_name}-${pkgver}"
@@ -36,5 +36,6 @@ build() {
package() {
cd "${_name}-${pkgver}"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ export PYTHONHASHSEED=0
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}