summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c6d8936aaa1..4cef94b46611 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,23 @@
pkgname=python-aadict
_pkgname=aadict
pkgver=0.2.3
-pkgrel=1
+pkgrel=2
_file=
pkgdesc="An auto-attribute dict (and a couple of other useful dict functions), for Python"
url="https://pypi.org/project/aadict/"
arch=('any')
license=('GPLv3')
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel')
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('a77328ac55dbb5735da99441870251befe135f687ab707a7a178561363b27704')
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd ${_pkgname}-${pkgver}
- python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+ cd "${_pkgname}-${pkgver}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}