summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 70ae59b9c4ff..6ab7360c53ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: razer <razer[at]neuf[dot]fr>
pkgname=python-adafruit-platformdetect
-_pypi_pkgname=Adafruit-PlatformDetect
-pkgver=3.63.0
+_pypi_foldername=Adafruit_PlatformDetect
+_pypi_pkgname=adafruit_platformdetect
+pkgver=3.69.0
pkgrel=0
pkgdesc="Platform detection for use by libraries like Adafruit-Blinka"
arch=('any')
url="https://github.com/adafruit/Adafruit_Python_PlatformDetect"
license=('MIT')
-source=("https://pypi.io/packages/source/A/${_pypi_pkgname}/${_pypi_pkgname}-${pkgver}.tar.gz")
+source=("https://pypi.io/packages/source/A/${_pypi_foldername}/${_pypi_pkgname}-${pkgver}.tar.gz")
makedepends=(
'python-build'
'python-installer'
@@ -15,7 +16,7 @@ makedepends=(
'python-setuptools-scm'
)
depends=('python')
-sha256sums=('6e7b5c3ff3f47a842c8c84107092edb17b0f712ca5295354a7e7ff442fd4e66e')
+sha256sums=('27ee15480fb6c5908da0bac808d5e99881bcb54e9c9ce9f81231273755451985')
build() {
cd "${srcdir}/${_pypi_pkgname}-${pkgver}"
@@ -27,3 +28,4 @@ package() {
python -m installer --destdir="$pkgdir" dist/*.whl
install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}
+