summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 15 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f1e41f45260b..9ad29a96c7cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,30 @@
# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
pkgname=('python-axelrod')
-pkgver=4.4.0
-pkgrel=2
+pkgver=4.13.0
+pkgrel=1
pkgdesc="Research tool for the Iterated Prisoner's Dilemma"
arch=('any')
url='https://github.com/Axelrod-Python/Axelrod'
license=('MIT')
-makedepends=('python-setuptools')
-depends=('python-dask'
- 'python-matplotlib' 'python-numpy' 'python-pandas'
- 'python-prompt_toolkit' 'python-pygments' 'python-scipy'
- 'python-tqdm')
+checkdepends=('python-hypothesis')
+makedepends=('python-setuptools' 'python-prompt_toolkit')
+depends=('python-dask' 'python-matplotlib' 'python-numpy' 'python-pandas'
+ 'python-yaml' 'python-scipy' 'python-tqdm')
+optdepends=('python-prompt_toolkit: enable the Human strategy')
options=(!emptydirs)
-sha256sums=('1f8f8386ab292877e9c063aa371e0d5709a969cce9cba828ee95567be1858c7e'
- '4d9d11b7d8ccd2074295b92b4961fd76b25e3948cb8e9836acd0123a5b6166f2')
-source=("$url/archive/v$pkgver.tar.gz"
- "$url/commit/8dba4c0.patch")
+sha256sums=('b0e1f58c3220bd6e8fb2ce8bf60e35c785dbeaa32e82e0d23361fd7bd7267e60')
+source=("$pkgname-v$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
prepare() {
cd "$srcdir/Axelrod-$pkgver"
- # Reverse the 8dba4c0 commit as we have prompt_toolkit v2, not v1
- patch -Rp1 < "$srcdir/8dba4c0.patch"
+ # No longer necessary but avoids messing with dask dependencies
+ echo > "requirements/requirements.txt"
+}
- # Avoid installing optional/unrequired dependencies
- echo > "requirements.txt"
+check() {
+ cd "$srcdir/Axelrod-$pkgver"
+ ./test
}
package() {