summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e1b696b6de3..f0610ba28eca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,9 +13,10 @@ license=('MIT')
depends=('python' 'python-aiohttp' 'python-dateparser'
'python-requests' 'python-ujson' 'python-websockets=9.1')
makedepends=('git' 'python-setuptools')
+checkdepends=('python-pytest' 'python-requests-mock')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+https://github.com/sammchardy/$_pkgname.git")
+source=("git+$url.git")
sha512sums=('SKIP')
pkgver() {
@@ -28,6 +29,11 @@ build() {
python setup.py build
}
+check() {
+ cd $_pkgname
+ pytest
+}
+
package() {
cd $_pkgname
python setup.py install --root="$pkgdir" --optimize=1 --skip-build