summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 19 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 693f8d3e8ff7..1586c03efc89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-bump-my-version
_name=$( echo ${pkgname#python-} | tr '-' '_' )
-pkgver=1.0.2
+pkgver=1.1.1
pkgrel=1
pkgdesc='A small command line tool to simplify releasing software by updating all version strings'
arch=(any)
@@ -20,10 +20,20 @@ depends=(
python-wcmatch
python-httpx
)
-makedepends=(python-build python-installer python-wheel python-setuptools)
-checkdepends=(python-pytest python-uv python-freezegun python-pytest-localserver python-pytest-mock python-pytest-xdist)
+makedepends=(python-build python-installer python-wheel python-hatch)
+checkdepends=(
+ git
+ mercurial
+ python-pytest
+ python-uv
+ python-freezegun
+ python-pytest-cov
+ python-pytest-localserver
+ python-pytest-mock
+ python-pytest-xdist
+)
source=(https://github.com/callowayproject/bump-my-version/releases/download/${pkgver}/${_name}-${pkgver}.tar.gz)
-sha256sums=('2f156877d2cdcda69afcb257ae4564c26e70f2fd5e5b15f2c7f26ab9e91502da')
+sha256sums=('2f590e0eabe894196289c296c52170559c09876454514ae8fce5db75bd47289e')
build() {
@@ -35,10 +45,14 @@ check() {
cd "$_name-$pkgver"
# Use pytest-xdist to speed up the tests, although it is not used upstream
- uv run pytest --no-cov -n auto tests/
+ GIT_AUTHOR_NAME="Your Name" EMAIL="you@example.com" uv run pytest --no-cov -n auto tests/
}
package() {
cd "$_name-$pkgver"
python -m installer --destdir="$pkgdir" dist/*.whl
+
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+
}