summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f43cbb0fb8a7..cac1e434a23c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
_pkgname=python-constraint
pkgname=$_pkgname-git
-pkgver=1.4.0.r4.ge23fe98
-pkgrel=2
+pkgver=2.0.0b3.r10.g2357471
+pkgrel=1
pkgdesc="Solvers for Constraint Satisfaction Problems (CSPs) over finite domains in simple and pure Python"
arch=(any)
url="https://github.com/python-constraint/python-constraint"
license=('BSD')
-depends=('python')
-makedepends=('git' 'python-setuptools')
-checkdepends=('python-pytest')
+depends=('python' 'cython')
+makedepends=('git' 'python-setuptools' 'python-poetry' 'python-build' 'python-installer' 'python-wheel')
+checkdepends=('python-pytest' 'python-pytest-cov' 'python-pep440')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
source=("git+$url.git")
@@ -26,20 +26,20 @@ pkgver() {
build() {
cd "$_pkgname"
- python setup.py build
+ # There's a build.py file in the root, so `python -m build` will run that instead!
+ pyproject-build --wheel --no-isolation
}
check() {
cd "$_pkgname"
- touch tests/__init__.py
- pytest
+ pytest --no-cov
}
package() {
cd "$_pkgname"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}