summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 38b54eaacfef..e22b56ec0c75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,12 @@
pkgname=('python-cov-core' 'python2-cov-core')
_distname=cov-core
pkgver=1.15.0
-pkgrel=1
+pkgrel=2
pkgdesc='plugin core for use by pytest-cov, nose-cov and nose2-cov'
arch=('any')
license=('MIT')
url='https://github.com/schlamar/cov-core'
+makedepends=("python-setuptools" "python2-setuptools" "python" "python2")
source=("http://pypi.python.org/packages/source/c/$_distname/$_distname-$pkgver.tar.gz")
md5sums=('f519d4cb4c4e52856afb14af52919fe6')
@@ -19,7 +20,6 @@ prepare() {
package_python-cov-core() {
depends=('python' 'python-coverage')
- makedepends=("python-setuptools")
cd "$srcdir/$_distname-$pkgver"
python setup.py install --root="$pkgdir"/ --optimize=1
@@ -27,7 +27,6 @@ package_python-cov-core() {
package_python2-cov-core() {
depends=('python2' 'python2-coverage')
- makedepends=("python2-setuptools")
cd "$srcdir/$_distname-$pkgver-python2"
python2 setup.py install --root="$pkgdir"/ --optimize=1