summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 420d7f4e9978..cb6aa11cec91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Victor Roest <victor@xirion.net>
pkgname=python-crossrefapi
_name=${pkgname#python-}
-pkgver=1.5.0
+pkgver=1.6.0
pkgrel=1
pkgdesc='Python Library that implements the endpoints of the Crossref API'
arch=('x86_64')
url='https://github.com/fabiobatalha/crossrefapi'
license=('BSD')
depends=('python-requests')
+makedepends=('python-poetry')
source=("https://files.pythonhosted.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
-sha512sums=('d6c6250e1c009e1cc960236a11b6fee9c64fe990c8cd879eca52684702a202f14668774d9a9959dc10c7a958908b4e7977fca0d989479817c303da0aa4839fbe')
+sha512sums=('78ca93a17c15e0d094b0e06054ec74ff13f8fe29ec3ce73ec768f8b197e620e4baac238c22bac802f9e5ea0498f4554c91d187e5b7ddaf87a717123e87778e26')
build() {
cd "$_name-$pkgver"
- python setup.py build
+ poetry build
}
package() {
cd "$_name-$pkgver"
- export PYTHONHASHSEED=0
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}