summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index db4616706a7a..bbcc84e8fb74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,22 @@
# Maintainer: Gerard Ribugent <ribugent <at> gmail <dot> com>
pkgname=python-datadog
_name=datadog
-pkgver=0.45.0
+pkgver=0.47.0
pkgrel=1
pkgdesc="The Datadog Python library and dogshell"
arch=(any)
url="https://github.com/DataDog/datadogpy"
license=('BSD')
depends=(
- 'python>=3.5'
+ 'python>=3.7'
'python-requests>=2.6.0'
)
+devdepends=(
+ 'python-hatchling>=0.15.0'
+)
makedepends=(python-build python-hatchling python-installer python-wheel)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/${_name//-/_}-$pkgver.tar.gz")
-sha512sums=('cfd67c7717d638cf70bbf4874f7645bfaa38e6925b01db1f312f4ee1303214650e8a7fe51024b742785443f57cd6763ea262063ba5dba9c37a7a5fd7084ed735')
+sha512sums=('de7ac3654d147c63203869197c65b924eca4e6c3fe490352a4858c36a8e789d30d01eef6711eaa633630045e14ef3811252ce0485cb777c79b19b42470c10376')
build() {
cd "$_name-$pkgver"