summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e2455e76ac4..bd67a90a5a8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,9 @@
-# Maintainer: Gaël Donval <gdonval+aur at google mail>
+# Maintainer: Hao Long <aur@esd.cc>
# Contributor: Gaël Donval <gdonval+aur at google mail>
-pkgbase='python-datashape'
-pkgname=('python-datashape')
-pkgver=0.5.3
-pkgrel=2
+pkgname=python-datashape
+pkgver=0.5.4
+pkgrel=1
pkgdesc='Data description protocol for dynd similar to Numpy DTypes.'
arch=('any')
url='https://github.com/blaze/datashape'
@@ -12,12 +11,10 @@ license=('BSD')
groups=('blaze-ecosystem')
makedepends=('python-setuptools')
depends=('python-numpy>=1.7'
- 'python>=3.4'
'python-multipledispatch>=0.4.7'
'python-dateutil')
source=("https://github.com/blaze/datashape/archive/${pkgver}.tar.gz")
-sha1sums=('e79b5eb684a698509cf8d46138fa717fa6826e2a')
-md5sums=('e243704f530ef7520ad9d5a70d337683')
+sha256sums=('c266c5803dde48b9fa8d8ee51b5b5979ef77443060e32db2d225b72648c638a5')
build() {
cd "${srcdir}"/datashape-$pkgver
@@ -26,7 +23,7 @@ build() {
package_python-datashape() {
cd "${srcdir}"/datashape-$pkgver
- python setup.py install --skip-build --prefix=/usr --root="$pkgdir" --optimize=1
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
install -D -m644 LICENSE* "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -D -m644 README* "${pkgdir}/usr/share/doc/${pkgname}/README"
}