summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37d42cb7f0f7..46cbb7956d7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Jeremy Gust <jeremy AT plasticsoup DOT net>
+# Maintainer: Jeremy Gust <jeremy AT plasticsoup DOT net>
# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Batuhan Baserdem <lastname dot firstname at gmail>
pkgname=python-desktop-notifier
pkgver=3.5.6
-pkgrel=2
+pkgrel=3
pkgdesc='Python library for cross-platform desktop notifications'
arch=('any')
url="https://github.com/SamSchott/desktop-notifier"
@@ -16,10 +16,10 @@ depends=('python'
makedepends=('python-build'
'python-installer'
'python-setuptools'
-# 'python-sphinx'
-# 'python-sphinx-autoapi'
-# 'python-sphinx-furo'
-# 'python-sphinx_mdinclude'
+ 'python-sphinx'
+ 'python-sphinx-autoapi'
+ 'python-sphinx-furo'
+ 'python-sphinx_mdinclude'
'python-wheel')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('c8bcfcbb49bcc763d9b2af1caea18c4fd4cf2a91238da1f4cfd6d7537622735a')
@@ -32,14 +32,14 @@ prepare() {
build() {
cd "${pkgname#python-}-$pkgver"
python -m build --wheel --no-isolation
-# cd docs
-# sphinx-build -b man ./ ./_build/man/
+ cd docs
+ sphinx-build -b man ./ ./_build/man/
}
package() {
cd "${pkgname#python-}-$pkgver"
python -m installer --destdir="${pkgdir}/" dist/*.whl
install -Dvm644 README.md "${pkgdir}/usr/share/doc/$pkgname/README.md"
-# install -Dvm644 docs/_build/man/desktop-notifier.1 "${pkgdir}/usr/share/man/man1/$pkgname.1"
+ install -Dvm644 docs/_build/man/desktop-notifier.1 "${pkgdir}/usr/share/man/man1/$pkgname.1"
install -Dvm644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
}