summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5dac38ff5421..7b6b917c72e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,28 @@
# Maintainer: KokaKiwi <kokakiwi+aur@kokakiwi.net>
pkgname=python-dhall
-pkgver=0.1.14
+pkgver=0.1.15
pkgrel=1
pkgdesc="Python bindings for dhall, a functional configuration language"
arch=('x86_64' 'i686')
url="https://pypi.org/project/dhall"
license=('Apache' 'MIT')
depends=('python' 'openssl')
-makedepends=('python-pip' 'cargo' 'maturin')
+makedepends=('cargo' 'python-build' 'python-maturin' 'python-installer' 'python-wheel')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/s-zeng/dhall-python/archive/v${pkgver}.tar.gz")
-sha256sums=('d6b95f03d25c80a39267891b6401be6af411e5eac44591a1654267a96533c06c')
-b2sums=('368857a5ef25d8fd0175ade30338a02fb0f91ffa5df340cc1b9ce7816f9724734a2e841ebe10c073d55c5d5136f3a62c67837a905f2c3656efbe26b36b71d9bf')
+sha256sums=('f2035d053a18cbcc943d614333cf2f719e225cd61555e6ec2c89f1c87480c923')
+b2sums=('8bf32de73ed467e5d2916ebeeef8cd14cfe7b13351ed521ff96ae264b705669f84015cb96ba62f6532f44700ed24b4a884f6e4ce86b9c1342e4185626d621f8d')
build() {
cd "dhall-python-${pkgver}"
- maturin build --release --manylinux off
+ OPENSSL_NO_VENDOR=1 python -m build --wheel --no-isolation
}
package() {
cd "dhall-python-${pkgver}"
- PIP_CONFIG_FILE=/dev/null pip install \
- --isolated --root="${pkgdir}" --ignore-installed --no-deps \
- target/wheels/dhall-${pkgver}-*.whl
+ python -m installer --destdir="$pkgdir" target/wheels/dhall-$pkgver-*.whl
install -Dm0644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE-*
}