summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e5a5ad2c1a6e..504df97d8349 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,23 @@
pkgname=python-diskcache
pkgver=5.6.3
-pkgrel=1
+pkgrel=2
pkgdesc="Python disk and file backed cache library"
arch=('any')
-license=('Apache')
+license=('Apache-2.0')
url="https://github.com/grantjenks/python-diskcache"
-makedepends=('python-setuptools')
+depends=('python')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/grantjenks/python-diskcache/archive/v${pkgver}.tar.gz")
sha256sums=('ecd01a006c60c68171571da77d905878bacc2103a8e0ade55dcda26271ea2bb3')
build() {
cd "${srcdir}"/"${pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${srcdir}"/"${pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+ python -m installer --destdir="$pkgdir" dist/*.whl
}