summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21d885fe823b..ede23ac78882 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,27 @@
pkgname=python-fastprocess
_pkgname=fastprocess
pkgver=2.0.0
-pkgrel=1
+pkgrel=5
pkgdesc='A fast subprocess library'
arch=('any')
url='https://github.com/dstathis/fastprocess'
-license=('LGPL')
+license=('LGPL-3.0-or-later')
makedepends=(
- 'python-setuptools'
+ python-build
+ python-installer
+ python-setuptools
+ python-wheel
)
-source=("https://github.com/dstathis/fastprocess/archive/${pkgver}.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/dstathis/fastprocess/archive/${pkgver}.tar.gz")
sha512sums=('194bcf0b1ee094a836df624514b8125712431ef57f01063e6cf799dd3cae3e45b1573756cd8c8eec03837632159a5cd99e0d0cbab864d0dea0ab9527eb4d6a1f')
build() {
cd "${_pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}
# vim:set ts=2 sw=2 et: