summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d36dc5b1b4d9..11e357cf02c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,27 +3,34 @@
# shellcheck disable=2148
pkgname='python-frontmatter'
-pkgver=0.5.0
+pkgver=1.0.0
pkgrel=1
-pkgdesc="parse and manage posts with YAML frontmatter"
+pkgdesc="Parse and manage posts with YAML (or other) frontmatter"
arch=('any')
url="https://pypi.org/project/python-frontmatter/"
license=('MIT')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('3b2acbcc68646e9e9868f3b10f7e6782')
+md5sums=('3718ee8fa3b0d4e5b262c9895ef44b81')
+depends=('python-toml' 'python-yaml')
+makedepends=('python-build' 'python-installer' 'python-wheel')
+checkdepends=('python-pytest')
build() {
# shellcheck disable=2154
cd "$srcdir"/$pkgname-$pkgver || exit 1
- python setup.py build
+ python -m build --wheel --no-isolation
+}
+
+check(){
+ cd "$srcdir/$pkgname-$pkgver" || exit 1
+
+ pytest
}
package() {
cd "$srcdir"/$pkgname-$pkgver || exit 1
# shellcheck disable=2154
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
-
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ python -m installer --destdir="$pkgdir" dist/*.whl
}