summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dec60fbdb84d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname=python-ghstats
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Python script to obtain GitHub Release download count and other statistics"
+url="https://pypi.org/project/ghstats/"
+arch=(any)
+license=('MIT')
+makedepends=('python-setuptools')
+source=("https://pypi.io/packages/source/g/ghstats/ghstats-${pkgver}.tar.gz")
+md5sums=('4e7f3548215dcc8f9814139001965bd1')
+
+build() {
+ cd "${srcdir}"/ghstats-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/ghstats-$pkgver"
+ python setup.py install --root=${pkgdir} --optimize=1
+}