summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b0760173bf2..454c17e9d5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor:
pkgname=python-gpy
-pkgver=1.9.2
-pkgrel=3
+pkgver=1.9.5
+pkgrel=1
pkgdesc="Gaussian processes framework in python"
arch=("any")
license=("BSD")
@@ -11,10 +11,15 @@ url="https://github.com/SheffieldML/GPy"
depends=('python' 'python-numpy' 'python-scipy' 'python-six' 'python-paramz' 'python-matplotlib' 'python-climin-git')
optdepends=('python-plotly' 'ipython' 'python-sphinx' 'python-ipykernel' 'python-ipywidgets' 'python-jupyter_client' 'jupyter-notebook' 'python-mpi4py')
makedepends=('python-setuptools' 'python-numpy' 'cython')
-source=("https://github.com/SheffieldML/GPy/archive/v${pkgver}.tar.gz")
-sha512sums=("50dc3627a05b9fc2fbc61204cf492e89d5c067da7aca3e738c52cc3c06652aa825e27e66b0a14a2e67e074cd19a75ab564449a762f1de1ba27a02fc986432403")
+source=("https://github.com/SheffieldML/GPy/archive/v${pkgver}.tar.gz"
+ "cython-v1.9.5.patch")
+sha512sums=("e4d45b426977ef1d987ffde9275adeeac3eb85874cee4049f40a255c14a54ebcfb7e1c402046af6818e20a7b166e51162731d3d904f2e43e830519c6c9489ae2"
+ "1c173cdac44e13663a6320528fa4a772c17adb37039dbda34633f1d4912ea5c3192cc7b13ac61bc036e06c538e5b5b63201b3a72ca7ebc37234dd2643e62ac0e")
prepare() {
+ # Fix Cython compilation errors (https://github.com/SheffieldML/GPy/pull/677)
+ patch -p1 -i cython-v1.9.5.patch
+
cd "GPy-${pkgver}"
# Forcibly update cython for python 3.7 (https://github.com/SheffieldML/GPy/issues/649)