summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e332f67a2ed0..8bd72dd1e81d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,27 @@
pkgname='python-hmms'
_name='hmms'
-pkgver=0.1
+pkgver=0.2.3
pkgrel=1
pkgdesc='Discrete-time and continuous-time hidden Markov model library'
url='https://pypi.python.org/pypi/hmms'
depends=('python' 'cython' 'ipython' 'python-matplotlib' 'jupyter-notebook' 'python-numpy' 'python-pandas' 'python-scipy')
+makedepends=(python-build python-installer python-wheel) #python-pytest-runner)
license=('Public Domain')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-md5sums=('0d586c8d120355328e5a96ba4da9c950')
+sha256sums=('16b622a5d14719c0e98b6cf1b01540cbcee967425a42d117bca6307fe5ba289f')
build() {
- cd "${srcdir}/${_name}-${pkgver}"
- sed -i 's/include_dirs/include_path/' setup.py
- python setup.py build
+ cd ${srcdir}/${_name}-${pkgver}
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/${_name}-${pkgver}"
- python setup.py install --root="${pkgdir}/" --optimize=1
+ cd ${srcdir}/${_name}-${pkgver}
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
+#check() { # I don't know how to make this work since it depends on python-hmms being installed
+# cd "${srcdir}/${_name}-${pkgver}"
+# pytest test/
+#}