summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 7 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f451052a760a..653dcd0c5fa4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,23 @@
-pkgbase=python-hope
-pkgname=('python-hope' 'python2-hope')
-pkgver=0.6.1
+pkgname=python-hope
+pkgver=0.7.3
pkgrel=1
pkgdesc="A Python Just-In-Time compiler for astrophysical computations"
url="https://github.com/cosmo-ethz/hope"
arch=(any)
license=('GPL')
-makedepends=('python-setuptools' 'python2-setuptools')
-source=("https://github.com/cosmo-ethz/hope/archive/${pkgver}.tar.gz")
-md5sums=('2218151116f010d55a752b591408be81')
+makedepends=('python-setuptools')
+depends=('python-numpy' 'python-sympy')
+source=("https://pypi.io/packages/source/h/hope/hope-${pkgver}.tar.gz")
+sha256sums=('f038b44da0b787f6ac5d07c21fdb51bfef953d9c039427e4097dbb7ffbb79a79')
build() {
- cp -r "${srcdir}"/hope-$pkgver "${srcdir}"/hope-$pkgver-py2
-
cd "${srcdir}"/hope-$pkgver
python setup.py build
-
- cd "${srcdir}"/hope-$pkgver-py2
- python2 setup.py build
}
-package_python-hope() {
- depends=('python-numpy' 'python-sympy')
-
+package() {
cd "${srcdir}"/hope-$pkgver
python setup.py install --root="${pkgdir}" --optimize=1
}
-package_python2-hope() {
- depends=('python2-numpy' 'python2-sympy')
-
- cd "${srcdir}"/hope-$pkgver-py2
- python2 setup.py install --root="${pkgdir}" --optimize=1
-}