summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4efb6dc90875..94a5a8b89edd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
pkgname='python-ibm-cloud-sdk-core'
_name='ibm-cloud-sdk-core'
-pkgver=3.19.2
+pkgver=3.20.0
pkgrel=1
-pkgdesc="Core functionality required by Python code generated by the IBM Cloud OpenAPI SDK Generator"
+pkgdesc="Core python functionality required by the IBM Cloud OpenAPI SDK Generator"
url="https://github.com/IBM/python-sdk-core"
depends=('python-requests' 'python-dateutil' 'python-pyjwt')
makedepends=('python-setuptools')
-license=('Apache')
+license=('Apache-2.0')
arch=('any')
#source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
source=("https://github.com/IBM/python-sdk-core/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('85db83ea372cc1d04153caa88d583839487549bdb1e9504d8efc1d26b1d85885')
+sha256sums=('9d7637b7f70a0b4805cfa3c02213c42ebb48baa64020f6559221733c79b1291e')
build() {
cd "python-sdk-core-$pkgver"
@@ -22,6 +22,6 @@ build() {
package() {
cd "python-sdk-core-$pkgver"
python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
- rm -rd "${pkgdir}/usr/lib/python3.11/site-packages/test"
- rm -rd "${pkgdir}/usr/lib/python3.11/site-packages/test_integration"
+ rm -rd "${pkgdir}/usr/lib/python3.12/site-packages/test"
+ rm -rd "${pkgdir}/usr/lib/python3.12/site-packages/test_integration"
}