summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f23327fd887f..a75c37c7c42c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,26 @@
-# Maintainer: Shane Donohoe <shane@donohoe.cc>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Shane Donohoe <shane@donohoe.cc>
pkgname=python-iterfzf
-pkgver=0.4.0.17.3
-pkgrel=3
-pkgdesc="Pythonic interface to fzf, a CLI fuzzy finder"
+_pkgver=0.5.0.20.0
+pkgver=0.5
+pkgrel=1
+epoch=1
+pkgdesc="Pythonic interface to fzf"
arch=('any')
url="https://github.com/dahlia/iterfzf"
license=('GPL3')
-depends=('python')
-makedepends=('python-setuptools')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/dahlia/iterfzf/archive/${pkgver}.tar.gz")
-sha256sums=('91884eb65aae192461f9bc8ab2b2eaded07f950369e5802599d008bec191ced3')
+depends=('python-setuptools' 'fzf')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/i/iterfzf/iterfzf-$_pkgver.tar.gz")
+sha256sums=('2b6f04d87a7cba79d03c2bb83575bb4580f47502dc024a24fc5dc8c0cfbcc52f')
build() {
- cd "iterfzf-${pkgver}"
- python setup.py test
+ cd "iterfzf-$_pkgver"
+ python setup.py build
}
package() {
- cd "iterfzf-${pkgver}"
- python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ export PYTHONHASHSEED=0
+ cd "iterfzf-$_pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}