summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 02933030587e..53ae1cb7883a 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,24 @@
-#Maintainer: John Jenkins twodopeshaggy@gmail.com
-#Maintainer: Sean Anderson seanga2@gmail.com
-
+# Maintainer: Alad Wenter <alad@archlinux.org>
+# Contributor: John Jenkins twodopeshaggy@gmail.com
+# Contributor: Sean Anderson seanga2@gmail.com
pkgname=python-kitchen
-pkgver=1.2.5
-pkgrel=2
+pkgver=1.2.6
+pkgrel=5
pkgdesc="Useful snippets of python code"
url="https://github.com/fedora-infra/kitchen"
-depends=('python' )
-makedepends=('python' 'python-setuptools')
-conflicts=('python3-kitchen')
-license=('LGPLv2+')
+depends=('python')
+makedepends=('python-setuptools')
+license=('LGPL')
arch=('any')
-source=(https://github.com/fedora-infra/kitchen/archive/v$pkgver.tar.gz)
-md5sums=('35490785ed23c91bad1c083c7adbc39e')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('6963dd84819713aafdd55e5314dcce6df5a37430b62fd9c48770e9f1a467b2b0')
build() {
- cd $srcdir/kitchen-$pkgver
+ cd "kitchen-$pkgver"
python setup.py build
}
package() {
- cd $srcdir/kitchen-$pkgver
+ cd "kitchen-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}