summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 18 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e7a0a01c424..8f76f9241e59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Tim Jester-Pfadt <t.jp at gmx.de>
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: Tim Jester-Pfadt <t.jp at gmx.de>
pkgname=python-lasagne-git
-pkgver=567.b22500e
+pkgver=0.1.r371.g5d3c63c
pkgrel=1
pkgdesc='Lasagne is a lightweight library to build and train neural networks in Theano.'
arch=(x86_64)
@@ -14,32 +15,32 @@ makedepends=('git' 'python-setuptools')
provides=('python-lasagne')
pkgver() {
- cd "$srcdir"/lasagne
- echo $(git rev-list --count master).$(git rev-parse --short master)
+ cd "$srcdir/lasagne"
+ # cutting off 'v' prefix that presents in the git tag
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd lasagne
- python setup.py build
+ cd "$srcdir/lasagne"
+ python setup.py build
}
check() {
- cd lasagne
- python setup.py test --verbose
+ cd "$srcdir/lasagne"
+ python setup.py test --verbose
}
package() {
- cd lasagne
+ cd "$srcdir/lasagne"
- # We don't need anything related to git in the package
- rm -rf .git*
+ # We don't need anything related to git in the package
+ rm -rf .git*
- # script tries to force develop mode - force install mode by echoing install to the script
- echo "install" | python setup.py install --root="${pkgdir}" --optimize=1
+ python setup.py install --root="${pkgdir}" --optimize=1
- # Install License
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # Install License
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- # Install Documentation
- install -D -m644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ # Install Documentation
+ install -D -m644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}