summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd7251af1dbf..565fe02831f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,6 @@
# Maintainer: D. Can Celasun <can[at]dcc[dot]im>
pkgname=python-mdx-gh-links
-_pkgname=mdx_gh_links
-pkgver=0.2
+pkgver=0.3
pkgrel=1
pkgdesc="An extension to Python-Markdown which adds support for shorthand links to GitHub users, repositories, issues and commits."
arch=('any')
@@ -9,16 +8,16 @@ url="https://pypi.org/project/mdx_gh_links/"
license=('MIT')
depends=('python')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/38/e7/76324cb45a3b655a3f4392e5e1c771a1b9a6b938700d7f9ac31fcbb43377/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('59fb8dafdf62bd0757593d6ab1f13b554d1d3ef0dcc44bedea2eca71970cf398')
+source=("https://github.com/Python-Markdown/github-links/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('4bd219c8f64dd017e9df18b33f87bb3f88efda428081ee4dd48508419517a538')
build() {
- cd "${_pkgname}-$pkgver"
+ cd "github-links-$pkgver"
python setup.py build
}
package() {
- cd "${_pkgname}-$pkgver"
+ cd "github-links-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"