summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6996c204b474..72e290af1b43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
# Maintainer: Paul Irofti <paul@irofti.net>
_name=openml
pkgname="python-$_name"
-pkgver=0.13.1
+pkgver=0.15.1
pkgrel=1
pkgdesc="python interface for OpenML"
arch=('any')
-url="http://openml.org/"
+url="https://openml.org/"
license=('BSD')
depends=('python' 'python-liac-arff' 'python-xmltodict' 'python-requests'
'python-scikit-learn' 'python-dateutil' 'python-pandas' 'python-scipy'
'python-numpy' 'python-minio' 'python-pyarrow')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('38ce7c32c28293cb1446d22e96e95e0352f7c62a5d88fe58ffdcad0e8c7a945b')
+sha256sums=('58ae3840b6ea736bb6c69bcbb30d587b817f64db070dc691adb9e09b99018816')
build() {
cd "$srcdir/$_name-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
# vim:set sw=2 et: