summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a05f3f65a404..b1a585ee9dde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,18 @@
-# Maintainer: gmes78 <gmes.078 at gmail dot com>
-
-# NOTE: building this package requires a nightly build of the Rust compiler.
+# Maintainer: Joaquim Monteiro <joaquim dot monteiro at protonmail dot com>
pkgname=python-orjson-git
-pkgver=2.5.2.r1.gd31e37b
-pkgrel=1
+pkgver=3.10.1.r0.g632345a
+pkgrel=2
pkgdesc="Fast, correct Python JSON library supporting dataclasses and datetimes (Git version)"
arch=(x86_64 i686 aarch64 armv7h)
url="https://github.com/ijl/orjson"
-license=('Apache' 'MIT')
+license=('Apache-2.0' 'MIT')
provides=('python-orjson')
conflicts=('python-orjson')
depends=('python')
-makedepends=('git' 'python-pip' 'rust')
+makedepends=('git' 'python-installer' 'python-maturin' 'rust')
source=("git+https://github.com/ijl/orjson.git")
sha512sums=('SKIP')
@@ -24,9 +22,13 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+build() {
+ cd orjson
+ maturin build --release --strip
+}
+
package() {
cd orjson
install -Dm644 LICENSE-MIT "$pkgdir/usr/share/licenses/$pkgname/LICENSE-MIT"
-
- PIP_CONFIG_FILE=/dev/null pip install --root="$pkgdir" --isolated --ignore-installed --no-deps --no-binary=orjson --use-pep517 .
+ python -m installer --destdir="$pkgdir" target/wheels/*.whl
}