summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0555036de81c..bffe850c64ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_base=pathos
pkgname=python-${_base}
pkgdesc="parallel graph management and execution in heterogeneous computing"
-pkgver=0.3.1
+pkgver=0.3.2
pkgrel=1
url="https://github.com/uqfoundation/${_base}"
arch=(any)
@@ -11,23 +11,23 @@ license=('custom:BSD-3-clause')
depends=(python-dill python-ppft python-pox python-multiprocess)
makedepends=(python-build python-installer python-setuptools python-wheel)
# checkdepends=(python-pytest)
-source=(${_base}-${_base}-${pkgver}.tar.gz::${url}/archive/${_base}-${pkgver}.tar.gz)
-sha512sums=('bc2d91c56976db88366ddff29abe6cde90f8e0a4d2aa03a357ecabd67448d927639670e2a1368a83dfa7f930e0cca0a6c6d0bfe2e504934e4e310e83de8c79f6')
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
+sha512sums=('962e11e53e836e360ffb8c5eec7c3ea46d3f505e5f212cd500905e0215ce3f942a0e476cb77b1bbf5046e3731469a71a090062a1aef3aa2acfb4c9f6ad8ef985')
build() {
- cd ${_base}-${_base}-${pkgver}
+ cd ${_base}-${pkgver}
python -m build --wheel --skip-dependency-check --no-isolation
}
# check() {
-# cd ${_base}-${_base}-${pkgver}
+# cd ${_base}-${pkgver}
# python -m venv --system-site-packages test-env
# test-env/bin/python -m installer dist/*.whl
# test-env/bin/python -m pytest ${_base}/tests
# }
package() {
- cd ${_base}-${_base}-${pkgver}
+ cd ${_base}-${pkgver}
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}