summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b04b2398379
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+#Maintainer: Gabriel Margiani <gabriel _strange_curved_character_ margiani ยท ch>
+pkgname='python-pathpy-git'
+pkgver=r432.fa06dc5
+pkgrel=1
+pkgdesc="Analysis of time series data on networks with higher- and multi-order graphical models"
+arch=('i686' 'x86_64')
+url="http://www.pathpy.net"
+license=('AGPL')
+provides=('python-pathpy')
+conflicts=('python-pathpy')
+depends=('python' 'python-numpy' 'python-scipy')
+makedepends=('python-setuptools')
+source=("$pkgname::git+https://github.com/uzhdag/pathpy.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $pkgname
+ python setup.py build
+}
+package() {
+ cd $pkgname
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+