summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0b38e2df56ab..bb3ec02e658e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
pkgname="python-plotly-git"
pkgver=5.1.0.r6.g17b7c27f9
-pkgrel=1
+pkgrel=2
pkgdesc="An open-source, interactive graphing library"
arch=("any")
url="https://plot.ly/python/"
license=("MIT")
-makedepends=("git" "npm" "python-jupyter_core" "jupyterlab" "python-setuptools" "python-tornado>=6.1.0")
+makedepends=("git" "npm" "python-jupyter_core" "jupyterlab" "python-setuptools" "python-build" "python-wheel" "python-installer" "python-tornado>=6.1.0")
provides=("python-plotly")
conflicts=("python-plotly")
-depends=("python>=3.6" "python-matplotlib" "python-numpy" "python-six" "python-retrying" "python-tenacity")
+depends=("python>=3.6" "python-matplotlib" "python-numpy" "python-tenacity")
optdepends=("ipython" "python-ipywidgets")
source=("git+https://github.com/plotly/plotly.py.git")
sha256sums=("SKIP")
@@ -24,10 +24,10 @@ pkgver(){
build(){
cd "plotly.py/packages/python/plotly"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package(){
cd "plotly.py/packages/python/plotly"
- python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}