summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 24 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61110bd86dd9..4b0b8182b804 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,34 @@
# Maintainer: Andy Kluger <https://t.me/andykluger>
# Maintainer: Florian Jacob <projects+arch AT florianjacob )DOT( de>
# Contributor: Milo Mirate <mmirate@gmx.com>
-_pkgname=plumbum
-pkgname=python-plumbum
-pkgver=1.7.0
-noise=ed/ba/431d7f420cd93c4b8ccb15ed8f1c6c76c81965634fd70345af0b19c2b7bc
-pkgrel=1
-pkgdesc="Shell combinators library."
-arch=('any')
+
+_name=plumbum
+_ghrepo=tomerfiliba/$_name
+
+pkgname=python-$_name
+pkgdesc="A small yet feature-rich Python library for shell script-like programs, and more"
url="https://pypi.python.org/pypi/plumbum"
-license=('MIT')
-groups=()
-depends=('python')
-makedepends=('python-pip')
-provides=()
-conflicts=()
-replaces=()
-backup=()
-# plumbum is plain python and therefore we don't need to run strip
-options=(!emptydirs !strip)
-# source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/tomerfiliba/plumbum/archive/v${pkgver}.tar.gz")
-source=("${_pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/${noise}/plumbum-${pkgver}.tar.gz")
+
+pkgver=1.7.0
+pkgrel=2
sha256sums=('317744342c755319907c773cc87c3a30adaa3a41b0d34c0ce02d9d1904922dce')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-package() {
- cd "$srcdir/${_pkgname}-$pkgver"
+depends=(python)
+makedepends=(python-setuptools python-setuptools-scm python-toml)
+optdepends=('python-paramiko: use pure Python for SSH2')
- python -m pip install --root "$pkgdir/" .
+arch=('any')
+license=('MIT')
+
+build () {
+ cd "$_name-$pkgver"
+ python setup.py build
}
-# vim:set ts=2 sw=2 et:
+package () {
+ cd "$_name-$pkgver"
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}