summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 583aae0e235a..1c453a235df4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,18 @@
_name=psaw
pkgname=python-$_name
pkgver=0.1.0
-pkgrel=1
+pkgrel=2
pkgdesc='Pushshift.io API Wrapper for reddit.com public comment/submission search'
arch=('any')
url="https://github.com/dmarx/$_name"
license=('BSD')
depends=(python python-requests python-click)
-makedepends=(install-wheel-scripts)
+makedepends=(python-installer)
_wheel="$_name-$pkgver-py3-none-any.whl"
source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/$_wheel")
sha256sums=('0d62ad9964dfbe9943b2089b25d3e44a7604794491a24a009c4262b2397fed6b')
noextract=("$_wheel")
package() {
- local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
- mkdir -p "$site"
- unzip "$_wheel" -d "$site"
- install-wheel-scripts --prefix="$pkgdir/usr" "$_wheel"
+ python -m installer --destdir="$pkgdir" "$_wheel"
}