summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 554720ec0973..f8a2c2186bb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,29 @@
_base=pyFFTW
pkgname=python-${_base,,}
pkgver=0.13.1
-pkgrel=3
+pkgrel=4
pkgdesc="A pythonic wrapper around FFTW"
arch=(i686 x86_64)
url="https://github.com/${_base}/${_base}"
-license=('custom:BSD-3-clause')
+license=(BSD-3-Clause)
depends=(fftw python-numpy)
makedepends=(python-build python-installer python-setuptools python-wheel cython)
checkdepends=(python-pytest python-scipy python-dask)
optdepends=('python-scipy: scipy.fftpack support'
'python-dask: dask.fft support') # openmp
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz
- cython3.patch::${url}/pull/363.patch)
+ cython3.patch::${url}/pull/363.patch
+ python312.patch::${url}/pull/370.patch)
sha512sums=('30a627e3abf62ac045478964265d7d675765354c118ad38f44c49748a86c8d7cf83eca872ae156f3a14219190140bfa04b8745a092e481f3df2a8ba417116b42'
- '9e754bfd3f75133250c0cb452316cf5b62e0473320f11cac4e7dc186aea8afcae0ae89cddcf7bb43d76beeaf8f6c7fd1de47dfe30c275739567117e62a8237dc')
+ '9e754bfd3f75133250c0cb452316cf5b62e0473320f11cac4e7dc186aea8afcae0ae89cddcf7bb43d76beeaf8f6c7fd1de47dfe30c275739567117e62a8237dc'
+ 'c568cf6d26024d7ec9e692a8c8fd3cc4aa19d09924a53ade83fa04af860fdf063cdfae885630da7aaa57edb58386978f0729313859681a1d37e77b48499f3e27')
prepare() {
cd ${_base}-${pkgver}
# https://github.com/pyFFTW/pyFFTW/issues/362
patch -p1 -i ../cython3.patch
+ # https://github.com/pyFFTW/pyFFTW/issues/366
+ patch -p1 -i ../python312.patch
}
build() {
@@ -38,7 +42,6 @@ check() {
cd ${_base}-${pkgver}
python -m venv --system-site-packages test-env
test-env/bin/python -m installer dist/*.whl
- # https://github.com/pyFFTW/pyFFTW/pull/370
test-env/bin/python -m pytest \
--ignore=tests/test_pyfftw_scipy_fft.py \
--ignore=tests/test_pyfftw_scipy_interface.py