summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9b9aa788519d..5702e348601c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Francisco Salces Carcoba <pacosalces@gmail.com>
# Contributor: Christopher Billington <chrisjbillington@gmail.com>
pkgname=python-pykat
-_name=PyKat
-pkgver=1.2.81
+_name=pykat
+pkgver=1.2.94
pkgrel=1
pkgdesc="Python interface and tools for FINESSE"
license=("GPL2")
-url="https://pypi.org/project/PyKat/"
-makedepends=('python-setuptools')
-depends=('finesse')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('6721071a852ac96603cb6afd4c79e25a1993b022580ff41dcb92c0b2eacf9f70')
+url="https://www.gwoptics.org/pykat/"
+depends=('finesse' 'python-numpy' 'python-scipy' 'python-six' 'python-h5py-git' 'python-pandas' 'python-matplotlib' 'python-tabulate' 'python-click')
+source=("git+https://git.ligo.org/finesse/$_name")
+sha256sums=('SKIP')
arch=('any')
build() {
- cd $srcdir/${_name}-$pkgver
+ cd $srcdir/${_name}
python setup.py build
}
package() {
- cd $srcdir/${_name}-$pkgver
+ cd $srcdir/${_name}
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}
+