summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2db1098a86f1..9e8a100f0f36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,27 +3,30 @@
_pkgname=pymodm
pkgname=python-pymodm
pkgver=0.4.3
-pkgrel=3
+pkgrel=7
pkgdesc='A Pythonic, object-oriented interface for working with MongoDB'
arch=('any')
url='https://github.com/mongodb/pymodm'
-license=('Apache')
+license=('Apache-2.0')
depends=(
python-pymongo
)
makedepends=(
+ python-build
+ python-installer
python-setuptools
+ python-wheel
)
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/mongodb/pymodm/archive/${pkgver}.tar.gz")
sha512sums=('d79ee3c1087dea9670faa715fa2ce1a1d4b1f156293e153d6a374b84dcdbdb6eae048653d599323499add4f1c7fb5cfb8671c9f8bfe927822051d6fc59e45dd2')
build() {
cd "${_pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}
# vim:set ts=2 sw=2 et: