summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 593d7aba7997..a3abfc7c8b7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,19 @@
pkgname=python-pysftp
_name=${pkgname#python-}
pkgver=0.2.9
-pkgrel=2
+pkgrel=3
pkgdesc="A simple interface to SFTP for Python"
arch=('any')
url="https://bitbucket.org/dundeemt/pysftp"
license=('BSD')
depends=('python' 'python-paramiko>=1.17')
makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel' 'curl')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-$pkgver.tar.gz")
-sha256sums=("fbf55a802e74d663673400acd92d5373c1c7ee94d765b428d9f977567ac4854a")
+source=(
+ "https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-$pkgver.tar.gz"
+ "https://bitbucket.org/dundeemt/pysftp/raw/1c0791759688a733a558b1a25d9ae04f52cf6a64/LICENSE.txt")
+sha256sums=(
+ "fbf55a802e74d663673400acd92d5373c1c7ee94d765b428d9f977567ac4854a"
+ "e648e3c7f439b52222a785a590223a0f7bad1a8a5fb89157d80d13123c7dcd25")
build() {
cd "$_name-$pkgver" || exit
@@ -21,6 +25,5 @@ build() {
package() {
cd "$_name-$pkgver" || exit
python -m installer --destdir="$pkgdir" dist/*.whl || exit
- curl "https://bitbucket.org/dundeemt/pysftp/raw/918494eef04e56f91cbff99c422bb57e21f4e257/LICENSE.txt" -o LICENSE.txt || exit
- install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+ install -Dm644 ../LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
}