summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 17 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8818de0ffb39..61a088e7e781 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,26 @@
-#Maintainer: Guillaume Dott <guillaume+github at dott dot fr>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Guillaume Dott <guillaume+github at dott dot fr>
pkgname=python-pysonic
-pkgver=0.7.7
+_pkg=py-sonic
+pkgver=1.0.0
pkgrel=1
-pkgdesc="A python library to wrap the Subsonic REST API"
+pkgdesc='Python library to wrap the Subsonic REST API'
arch=('any')
url="https://github.com/crustymonkey/py-sonic"
license=('GPL3')
-depends=(
- 'python-setuptools')
-makedepends=('python')
-provides=('python-pysonic')
-source=("https://github.com/crustymonkey/py-sonic/archive/${pkgver}.tar.gz")
-sha256sums=('2de521d5c79d73025f32ac261ab581bdef1e100c00e7fd0d8992310af662d998')
+depends=('python')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+changelog=CHANGELOG.md
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/p/$_pkg/$_pkg-$pkgver.tar.gz")
+sha256sums=('f61a3417991fef8a42b0bba3c0bb7ea54f88931bbbd3f924f963fb9670fb0a21')
+
+build() {
+ cd "$_pkg-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
- cd "$srcdir/py-sonic-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$_pkg-$pkgver"
+ python -m installer --destdir "$pkgdir" dist/*.whl
}