summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e235f2593392
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+
+pkgname=python-pyuavcan
+pkgver=0.9.0
+pkgrel=1
+pkgdesc='Python implementation of the UAVCAN protocol stack.'
+arch=('x86_64')
+url='https://pyuavcan.readthedocs.io'
+license=('MIT')
+depends=('python' 'python-pydsdl' 'python-numpy' 'python-nunavut')
+optdepends=('python-can' 'python-pyserial' 'python-ruamel-yaml'
+ 'python-requests' 'python-simplejson')
+makedepends=('python' 'python-setuptools')
+source=("${pkgname}-${pkgver}::https://github.com/UAVCAN/pyuavcan/archive/$pkgver.tar.gz")
+sha256sums=('55ab8ff71d5a5a5e26a8d5e2a83c309e08d1c36eefb784e8076427cc94dafdfc')
+
+_pkgname=pyuavcan
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir"/ --optimize=1
+}