summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d9fad5cbb64..dc0ea693dfaf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jonas Malaco <jonas@protocubo.io>
# Contributor: Alex Forencich <alex@alexforencich.com>
pkgname=python-pyusb-git
-pkgver=1.1.1.r6.g6bd82d9
+pkgver=1.2.1.r18.g629943a
pkgrel=1
pkgdesc="USB access for Python"
arch=('any')
@@ -9,6 +9,7 @@ url="https://github.com/pyusb/pyusb"
license=('BSD')
depends=('python' 'libusb')
makedepends=('git' 'python-setuptools' 'python-setuptools-scm')
+checkdepends=('python-pytest')
provides=('python-pyusb')
conflicts=('python-pyusb')
@@ -28,6 +29,11 @@ build() {
python setup.py build
}
+check() {
+ cd "$srcdir/$_gitname"
+ python -m pytest
+}
+
package() {
cd "$srcdir/$_gitname"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build